0

I am getting an error when running my spfx webpart with a picker picker control. When I do gulp server I get the error

ERROR:

Cannot find module 'ControlStrings'

I have googled this and have added ControlStrings: "node_modules/@pnp/spfx-controls-react/lib/loc/{locale}.js" to config.json file but get the same error.

Full error as follows:

Error: Cannot find module 'ControlStrings' at webpackMissingModule (https://localhost:4321/dist/pn-pjs-example-web-part.js:113406:45) at ql+0 (https://localhost:4321/dist/pn-pjs-example-web-part.js:113406:134) at webpack_require (https://localhost:4321/dist/pn-pjs-example-web-part.js:20:30) at Module.ZFCQ (https://localhost:4321/dist/pn-pjs-example-web-part.js:75176:120) at webpack_require (https://localhost:4321/dist/pn-pjs-example-web-part.js:20:30) at /4uW (https://localhost:4321/dist/pn-pjs-example-web-part.js:1674:108) at webpack_require (https://localhost:4321/dist/pn-pjs-example-web-part.js:20:30) at 891W (https://localhost:4321/dist/pn-pjs-example-web-part.js:19804:82) at webpack_require (https://localhost:4321/dist/pn-pjs-example-web-part.js:20:30) at https://localhost:4321/dist/pn-pjs-example-web-part.js:84:18

1 Answer 1

0

I solved this by uninstalling and reinstalling pnpjs react controls.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.