1

I have created a list on SharePoint in order to view it as a calendar. Since color coding isn't possible, I followed a web tutorial on using JSON to be able to color code different types of events.

I have put the Calendar view as the default view and when I open my calendar the color coding format does not appear. However, when I press on "All Items" view and then go back to the "Calendar View" I can finally see my color coding format on the Calendar View.

How can I make the color coding format visible on the Calendar View from the start please?

1
  • Can you show us the JSON you used and screenshot of calendar view if possible (add it your original question by editing it)? Make sure you have shown/added all columns in the calendar view (columns which you are referring in the JSON). Follow: sharepoint.stackexchange.com/questions/306473/…. let me know if it works for you. Commented Aug 28, 2023 at 13:01

2 Answers 2

0

You are likely referencing a column in your expression that is not a part of the calendar view. I would guess it's part of the All Items view which is why once you load that and come back, things work (the column value has now been retrieved).

In List Settings for your list, edit your calendar view using the classic settings page. Check the box for all referenced columns to ensure they are part of your view. No need to change anything else.

Verify if this fixes your problem by opening the view in an entirely new window or tab. If the issue persists, please update your question with the format and we can go from there.

1
  • Thank you all for answering my question so quickly! I was able to resolve the issue by going onto List Settings > Columns > [column which included my color coding] > answer "YES" to "require that this column contains information". I reckon this enabled my column to be seen on my calendar view
    – Ombeline
    Commented Aug 29, 2023 at 9:15
0

As mentioned in my above comment, I think you are using a column value in your SharePoint list calendar view JSON formatting which is not shown/added in your calendar view settings.

So, you have to change the calendar view settings and show/include the columns in list view to use in the calendar view formatting.

Follow below steps:

  1. Open the Calendar view in SharePoint list

  2. Click on Switch view options dropdown from the top.

  3. Select Edit current view.

    enter image description here

  4. Select the column you want to use for formatting

    enter image description here

  5. Click Save/OK at the bottom of view settings page.

  6. When you open the formatting pane again, the columns you selected in the Edit View screen will be displayed as available options for view formatting.

References:

  1. Conditional formatting in calendar view is not showing a column
  2. How to find the Internal name of columns in SharePoint Online? - You have to refer the column values in JSON formatting using their internal names
3
  • Thank you all for answering my question so quickly! I was able to resolve the issue by going onto List Settings > Columns > [column which included my color coding] > answer "YES" to "require that this column contains information". I reckon this enabled my column to be seen on my calendar view.
    – Ombeline
    Commented Aug 29, 2023 at 9:14
  • Great, I am glad it worked for you! Commented Aug 29, 2023 at 10:23
  • Please accept it as an Answer if it helped you in any way & it will help others with similar question in future. Commented Aug 29, 2023 at 10:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.