0

I have a Document Set defined and I created a default view on the library using the Tiles format, so it appears like this:

enter image description here

I want to have it so that when I click on the tile representing the Document Set, it switches to the normal folder/file view ("List") of a document library, like:

enter image description here

However, it always stays in the Tiles view.

I have a view I created "Tiles" and I made that the default view. In the view config, under "Folders", I have "Show items inside folders" and for "Show this View" I selected "In the top-level folder". It will not allow me to select "In folders of content type" - it is grayed out.

I created another view "Library" and under "Folders" for "Show this view" I selected "in folders of content type" and selected "Folder".

Then I put the Document Library web part on a page. It defaults to the Tiles view, but when I click on a Tile, it stays in the Tiles view - it does not switch to the "Library" view to just show the files and folders without the tiles.

Is there any way to do that?

1 Answer 1

0

Try these steps:

  1. Go to your SharePoint site page and open it in edit mode using "Edit" option at the top right corner

  2. Add new Library web part on the page

  3. In web part settings, select the view you formatted with "Tiles" view.

  4. Apply the changes to web part settings

  5. Publish/Republish the page

  6. It will show the tiles like this:

    enter image description here

  7. Then double click on the document set tile, which will open the library web part in normal table view structure like:

    enter image description here


Also, to select the specific content type under "In folders of content type" settings, you first have to select the radio button at the left:

enter image description here

If you go to List settings --> View section it will show your view like:

enter image description here


Update from comments:

I have 2 views in the document library:

  1. All Documents - Default view in the library shown in Tiles format and same view is selected in the Library web part settings on site page
  2. Admin View

Settings for All Documents:

enter image description here

Settings for Admin View:

enter image description here

12
  • That's where the disconnect is for me. On your step 7, if I double-click on the document set tile, it does not open it in the normal list view. It stays in Tile mode.
    – mannaggia
    Aug 24, 2023 at 14:10
  • I tested it and it works fine for me. Do you have "Admin View" in your document library? If yes, set the "Folders" options as shown in the last image in my answer. If no, create a new view and set the folders options. Select: In folders of content type: Document Set. Aug 24, 2023 at 14:13
  • OK, so here is what KIND OF works for me. I created a view "Tiles", set "Show this View" to "In folders of content type" and selected the content type of my Document Set., and added that web part to the page. I created a view called "Library" that is the List format and made that the Default View and chose "In the top-level folder". Now on the web part page, it shows the Tile View and a click on a tile switches to Library View. BUT... if I click on the name of the Doc Library in the breadcrumbs to get back to the root, it doesn't go back to Tile View. I have to refresh the page to get back.
    – mannaggia
    Aug 24, 2023 at 14:20
  • In my case, it goes back to Tiles view without any issues. I will update view settings and screenshots in my answer. Aug 24, 2023 at 14:23
  • So in your example, when you double click on the document set tile, then click on "DocumentSets" in the breadcrumbs, it goes back to tiles?
    – mannaggia
    Aug 24, 2023 at 14:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.