I am having trouble in installing Apps on a particular site collection, getting a message (SkipFeatureDeployment:false):

"You can't add app here" contact the administrator.

But the same apps are working when I am deploying them with SkipFeatureDeployment to true and making them available to all sites upon deployment in app catalog.

What could be the reason?

  • Do you have site collection administrator permissions on the site collection? Try using account with SCA permissions. Let me know if this works for you. Aug 22 at 5:18
  • Yes I am SCA , when I click the Find out Why link it is showing me a message "Sorry, apps are turned off. If you know who runs the server. tell them to enable apps"
    – RHM
    Aug 22 at 5:50
  • Are you using tenant level app catalog or site collection level app catalog? Try this once: natechamberlain.com/2020/10/19/… Aug 22 at 6:17
  • I am using Site collection level app catalog
    – RHM
    Aug 22 at 6:22

1 Answer 1


I am able to resolve the issue by adding appurl and appdomain

App Url was not configured => Chances are you have not configured the App Urls. Please ensure you have given values to App Domain and App Prefix in your App Store settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.