0

I have to download about 200GB of data from a Microsoft 365 sharepoint site on a Mac. The downloaded zip files seem to be broken.

enter image description here

I have tried downloading smaller folder and fewer set of files at a time etc. I have also tried three different browsers: chrome, safari and edge. Occasionally they work, but most zips do not work. Just searching around, it seems like this issue have been mentioned many times for many years, but I cannot find any solutions.

Is there any solution to make this work?

Update:

Also tried different OS: Mac, Ubuntu and Windows. It doesn't make a difference. File size is probably the main factor. Small files download fine. 1-2 GB files fail 60-70% of the time. 5GB and higher files are corrupted almost 100%.

1 Answer 1

0

There are known issues with the standard download functionality. For instance, when an item name contains a + character it will result in a corrupt zip file. It should not depend on the browser because the zip file is generated server-side. Trying to download 200 GB into a single zip file will also be a challenge using the SharePoint download functionality irrespective of any special characters. Another detail to be aware off is the modification date for the files in the zip file: that is set to the download time.

There are 3rd party apps (list) that overcome the problem with special characters. I do think you should try to break the 200 GB data set into smaller parts to avoid problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.