The subject pretty much says it all. I created a domain isolated webpart that uses the GraphClientv3 to talk to graph. it works fine when i run on a page in sharepoint. I added it to teams using the add to teams button in the new app catalog. but when i open it in teams it throws some error like ‘cannot get property (id) of undefined’.

Thought id ask here if it’s even supported before i go down the rabbit hole! Thanks

1 Answer 1


I did a minimal web part setup to test it and got a similar result to you when adding as a Personal App. Below is a shot of the error. However it worked when adding it as a Teams tab to a team. So maybe tabs are ok, but not personal apps.

enter image description here

Edit: Have discovered Teams tab isn't quite right either, the properties pane opens every time you navigate to the tab.

  • Thanks Paul. Indeed it does work fine as a teams tab!
    – RussGove
    Jun 23 at 13:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.