We have a SharePoint 2016 farm consisting of two servers configured with minroles. WFE (Front-End + Distributed Cache) and Application (Application with Search).

I noticed that the user profiles where not removing disabled accounts, even if they are not selected in the synchronization connection. I noticed that the User Profile Service (UPS) is configured on both servers, but it is only online on the APP server and provisioning/start on the WFE server. I tried to stop the service instance on the WFE server, but I get the error "An object of the type Microsoft.SharePoint.Administration.SPServiceInstanceJobDefinition named ... already exists under the parent... named SPTimerV4".

I installed the latest updates and re-ran the configuration wizard, but this didn't help.

I thought it might be the User Profile Service Application (UPSA) that might be corrupt, had that before on 2010. So I tried to delete the UPSA and create a new one. It didn't delete initially as it would just time out from Central Admin. I then unprovisioned it with PowerShell and then deleted it using the following:

$serviceApp = Get-SPServiceApplication -Name "User Profile SA"

The databases for the original UPSA are still on the SQL server.

I've been using the farm account in doing all these tasks and it is part of the local admin group.

The new UPSA is now stuck at starting as well.

I think I messed it up pretty good now.

Should I be focusing on getting the UPS out of "Stopping" status first? Can I remove the UPS from the WFE server and just run it off the APP server?

Any advice would be welcomed.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.