0

I have a Sharepoint 2019 on-premise instance running a web app with the following URL:

share.mangos.com

on port 80 without SSL enabled, I set up the SSL following the steps from this blog post:

https://blog.blksthl.com/2012/12/20/a-guide-to-https-and-secure-sockets-layer-in-sharepoint-2013/

A difference is that I am running Windows Server 2022 Eval with IIS 10.0, and didn't find IIS Resource kit for IIS 10, so I didn't run SelfSSL.exe inside the resource kit, so created the Self-Signed Certificate using IIS Manager on the same server running Sharepoint.

When I check on the browser

HTTP://share.mangos.com works fine but doesn't show or recognize the SSL Cert.

HTTPS://share.mangos.com doesn't connect and show the error Secure connection failed and Firefox did not connect

So what I am missing, or did wrong, or it is outdated the steps or there is another method? for Sharepoint 2019?

1 Answer 1

0

HTTP:// endpoint will not use certificate, so "doesnt's show SSL Cert" - is OK.

as for HTTPS:// endpoint:
if you're using the self-signed certificate on your website, then it must be aslo installed to your OS as Trusted Root CA Cert on the computer from which you connect to the site (Part 6 of the instruction you mentioned).

Also, Firefox can ignore OS certificates list and use its own list.
In that case you should add your self-signed cert to Firefox's inner certificate list (somewhere in Tools > Options > Advanced (or Privacy and Security) > Certificates: View Certificates - Authorities - Import)

1
  • oh, thanks for the reminder of that steps, the self-signed certificate is already installed on Trusted Root CA Cert as tried for Firefox importing but is still rejected.
    – ISeeMangos
    May 23, 2023 at 2:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.