1

I have successfully integrated SharePoint 2016 On Premise Site with ADFS.

When I hit the Site URL, it asks me to select either Windows Authentication Mode or ADFS.

I want the site to directly route me to ADFS page instead of asking the Authentication Mode.

enter image description here

Any Help would be highly appreciated.

Update:

Since I can't disable Windows Authentication in the Default Zone otherwise Crawler will fail.

I create a new Zone which will use ADFS Authentication Provider and configured it at Intranet Zone:

enter image description here

**

When I try to open the Site it returns the following error:

enter image description here

Kindly note that now my Site has two Zone:

Default: which is there to Enable Windows Authentication http://az-spfe-uat:27822/

Intranet: which is intended to be used for ADFS Authentication

Please Help

Update:

I configured Alternate Access Mapping as below & it worked!

enter image description here

1 Answer 1

0

To directly route to the ADFS page instead of asking for the Authentication Mode, you need to configure the SharePoint site to use ADFS as the default authentication provider. Here are the steps to do so:

  1. Open the SharePoint 2016 Central Administration site.
  2. Click on "Application Management" and then click "Manage web applications."
  3. Select the SharePoint web application you want to configure and click "Authentication Providers" from the ribbon.
  4. Select the "Default" zone and click "Edit."
  5. In the "Edit Authentication" page, select "Claims Authentication Types" and choose "Trusted Identity Provider" as the default.
  6. Select the ADFS provider you configured and move it to the top of the list.
  7. Click "OK" to save the changes.

After you complete these steps, the SharePoint site will directly route to the ADFS page for authentication.

Update:

Create Two Separate Zones to configure ADFS Authentication:

Default Zone: Enable Windows Authentication in order to enable the crawler to work

Intranet Zone: Enable ADFS on it and disable Windows Auth on it in order to land the user directly to the ADFS Login Page.

Configure Alternate Access Mappings Like:

enter image description here

4
  • Hi, I have disabled Windows Authentication and it is redirecting me directly to the ADFS page but it says " If Windows authentication is not selected on any Zone of this Web application, crawling for this Web application will be disabled." May 11, 2023 at 7:20
  • Hi, I have added an update in the Question, you can see details there. Thanks May 11, 2023 at 7:44
  • Thanks @pradip R. I have added some additional steps in your answer which make it worked! can you please look into this as well: sharepoint.stackexchange.com/questions/307748/… May 11, 2023 at 10:24
  • 1
    Glad that it worked for you!
    – Pradip R.
    May 11, 2023 at 11:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.