0

I have this workflow where I have two apply to each and many compose fields.

Is there a way to optimize this for faster execution? I am getting an error about slow running.

The excel table has only 1600 rows and I am only using about 5 columns to populate my sharepoint.

flow -

enter image description here

enter image description here

enter image description here

Compose statements are repeatable for date fields,

items('Apply_to_each')?[concat('Period Planned ', '/', ' Revised Date')] addDays('1899-12-30',int(outputs('Compose')),'yyyy-MM-dd')

enter image description here

enter image description here

4
  • Can you try enabling concurrency control from apply to each action settings? Let me know if it helps to reduce the flow run time. Apr 27, 2023 at 15:39
  • Looks to be faster..still running after 1 hour... 1530 records complete.. seems stuck on it lol. Expecting 1675 records roughly.
    – Jonnyboi
    Apr 27, 2023 at 19:01
  • it works!! only 1:30 min this time! Flow runs fine and populates everything correctly. But I still get an error ActionFailed. An action failed. No dependent actions succeeded. on compose 2... i wonder why.. could it be because of my pagnation limit?
    – Jonnyboi
    Apr 27, 2023 at 20:06
  • Maybe flow expression is not working, correctly either because of one of the inputs (excel column) is blank or is not in proper date/int format as expected. Apr 28, 2023 at 3:39

1 Answer 1

1

You can turn ON Concurrency Control option from the settings of the apply to each actions to reduce the flow run time.

These settings looks like this:

enter image description here

You can set the degree of parallelism as per your requirements.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.