When I go to manage service applications in Central Administration and try to create a new service application like: New > Create a new service application, the link isn't active. My issue is I would like to create a Search Service Application after installing Search Server Express 2010.

Do I need to run the Farm Configuration Wizard and install the below if I can create a Search Service Application?

Business Data Connectivity Service

Enabling this service provides the SharePoint farm with the ability to upload BDC models that describe the interfaces of your enterprises' line of business systems and thereby access the data within these systems.

State Service

Provides temporary storage of user session data for SharePoint Server components.

Usage and Health data collection

This service collects farm wide usage and health data and provides the ability to view various usage and health reports.

Update 1:

I'm running Windows 2008 R2. I migrated WSS v3 to SharePoint Foundation 2010 and then installed Search Express 2010 on top of it.

I am logged in with an account that has full farm administration access.

Update 2:

I migrated WSS v3 to Sharepoint Foundation 2010 and then installed Search Express 2010 on top of it.

Update 3:

Yes the farm admin acct is the member of the local admin. What services are required to start to have the possibility to create a new search service apps? The only new link i can see on the service application page menu is to create BDC service.

alt text http://www.freeimagehosting.net/uploads/13f9bedb07.jpg

  • @Patrick: Please make an effort to use this system properly. Most of all this helps you get good answers. If your post isn't gaining attention, edit it with more details on what you have tried. If you are responding to someone that has left you an answer, please leave a comment on their answer. Thank you
    – Alex Angas
    Jun 20, 2010 at 6:08
  • Run Internet Explorer as Administrator and open Central Administration site.
    – user39931
    Feb 24, 2015 at 19:49
  • You can follow steps in this link sharepoint.stackexchange.com/a/30962/29811
    – doganak
    Jul 1, 2015 at 16:32

4 Answers 4


is the UAC enable? So you have to open the Central Administration from start windows menu instead of opening a browser and type the url of the Central Administration... ...or disable UAC.

  • ran into this recently. that's my first bet.
    – 1c1cle
    Apr 28, 2012 at 23:41
  • Worked for me on Windows 2008R2 + SharePoint 2013. Thanks!
    – SomeGuy
    Jul 3, 2014 at 19:53

Are you running on Windows 7? If that is the case make sure that your Internet Explorer (or other browser) is running with elevated privilegies.


Is your farm administrator account member of the local administrator group on the farm servers? This is required to start services.


Are you logged in with an account that has full farm administration access? Are you using Foundation or the full server version?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.