2

I have a SharePoint Online List.

It has some fields that are 'Required' fields.

I am also trying to use List Validation so that:

  • IF the value of MyChoiceColumn is Yes
  • THEN the AdditionalInformation text field requires a value

MyChoiceColumn is a Choice field with two values - Yes and No.

AdditionalInformation is a Single Line of Text column.

I have entered this formula into List Settings > Validation:

=IF(MyChoiceColumn="Yes",IF(ISBLANK([Additional Information]),FALSE,TRUE),TRUE)

(note: the space in [Additional Information] is intentional and correct)

The formula syntax looks correct to me and I have seen the same syntax demonstrated here.

When I try and submit the form, it shows this error at the very TOP of the form:

enter image description here

The user message that I have entered in the list validation settings is not displayed.

The form also produces some quirky behaviour where a required Date field 'date picker' is automatically opened (even though a date was chosen prior to trying to submit the form).

Steps To Reproduce

  • Create a Microsoft List

  • Add a Date column named MyDateColumn and make it a required field

  • Add a Choice column named MyChoiceColumn with two values - Yes and No

  • Add a Single Line of Text column named AdditionalInformation

  • Rename the AdditionalInformation column so it has a space, i.e Additional Information

  • Go to List settings > Validation settings

  • Enter this formula:

=IF(MyChoiceColumn="Yes",IF([Additional Information]="",FALSE,TRUE),TRUE)

OR this formula:

=IF(MyChoiceColumn="Yes",IF(ISBLANK([Additional Information]),FALSE,TRUE),TRUE)
  • Enter this custom user message:

You have selected a response that requires further information be entered into this form

  • Save those settings

  • Go to the frontend of the form

  • Enter a date in the required date field

  • Select Yes in the MyChoiceColumn column

  • Leave the Additional Information blank

  • Click Save to submit the form

The following things happen:

  • My custom error message is not displayed

  • This error is displayed at the very top of the form:

Error: The server was unable to save the form at this time.
Please try again

  • The data picker for the Date column pops open

This is what should be happening:

  • The form displays my custom error message in a position that is relevant to where the error is occurring OR at the bottom of the form near the Save button
2
  • 1
    Seems like generic error message. Maybe temporary issue from Microsoft's end. I will try to reproduce and get back to you. Commented Apr 6, 2023 at 11:09
  • 1
    Not sure if you have seen my reply in comments section of answer by another user (it is deleted now). I want to thank you for the kind words and I am very happy to hear that my answers are helping you and your colleagues. Let's connect via LinkedIn or Blog contact page (Anonymous/Personal chat) if possible. Commented Apr 7, 2023 at 9:50

2 Answers 2

3

I followed the steps provided by you and I am able to reproduce this issue.

I have tried creating multiple lists and using different list validation formula with different "User Messages". But I am still receiving same error message mentioned by you in all the scenarios.

I think this is a temporary issue from Microsoft's end. I will suggest you to raise a support ticket with Microsoft directly and report this issue.

Follow documentation for same: Get M365 support - online support

10
  • 1
    Thank you very much for reproducing the issue, I submitted a support ticket around the same time I posted the original question, and the issue is still occurring, as soon as I get a resolution from Microsoft I will post back. Commented Apr 7, 2023 at 11:02
  • 1
    Also, I have started accepting "Buy me a coffee" support: ko-fi.com/ganeshsanap. This link is now available on my blog site as well at the right hand side bar on the blog pages. 😅 Commented Apr 20, 2023 at 2:24
  • 1
    I guess we have to wait until Microsoft fixes it completely and rollout the new update on all SharePoint tenants. Commented Apr 20, 2023 at 6:38
  • 1
    I just tested it on my SharePoint site and it is showing the custom message for me (Note: I am using targeted release tenant). Also, others confirmed it is working for them as well at: techcommunity.microsoft.com/t5/sharepoint/…. Try removing and re-adding the formula & user message once to check if it works. Commented Apr 20, 2023 at 10:36
  • 1
    I tried removing formula and message, saving, then re-adding, saving, clearing cache and reloading list. now the correct message is displaying, but it is still opening up the date picker field calendar for no reason (it already had a value selected). the end-user will think there is something wrong with the date picker field value when there is not. Commented Apr 20, 2023 at 23:24
0

I am having the same issue.

When I enter this validation:

=IF(Status="New",FALSE)

The error message is "Error: The server was unable to save the form at this time. Please try again."

I want the custom message to appear.

If I enter this validation:

=IF(Status="New",TRUE)

There is no error message and it saves correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.