I have added some columns to a Document Library. I want to use the PnP Modern Search Results V4 to display the results but I am stuck trying to get columns that I added to display. I'll use this "Related Client Number" column as my example. It's just a single line of text field.

This is one of my text columns

In the settings for the PnP webpart, I tried to Manage Columns but my "Related Client Number" column isn't an option in the dropdown. I've tried adding the column using handlebars express like {{getSummary (slot item @root.slots.Related Client Number)}} but I don't think I have the syntax right.

I have also tried adding the column to the Selected Properties settings in the PnP webpart. I don't see my columns there either.

3 Answers 3


You need to create managed properties for your column from SharePoint Admin Center. You can follow steps from below link:


Once managed properties is created and content is crawled, you will able to see this in "Select Properties" drop down in PnP Search Results settings.

Important: After creating managed property, it might take some time to available because it will be available after background crawl

  • I thought this might be correct but I could not see the "New Managed Property" link so I assume I don't have correct permissions. Thanks for clarifying and teaching me something new. I now know what to ask for from IT.
    – zkent
    Commented Mar 23, 2023 at 16:08
  • 1
    I have added a managed property. But It does not show in "Selected Properties" dropdown. Is there any more settings that we have to do? (its been weeks since I mapped it in search schema". I can use it in "Query template" just fine. Commented Mar 31, 2023 at 9:25
  • 1
    @KjetilYtrehus I had issues with this also. Try typing the property into the field and hitting Enter. When I did this, my property magically appeared in the list as selected. Ah, Microsoft.
    – zkent
    Commented Apr 18, 2023 at 14:22

I'm having a similar issue. I've created the managed metadata field (RefinableString100), I have it mapped to my field in the document library and I've selected in the PNP results webpart as Selected properties. I've got the refinement panel working with the RefinableStrings, but for some reason I cannot display the RefinableString data in the results template. I want to show the Sections applicable to each of the items in the search results. I'm trying this with the following handle bar code in the template: {{slot item @root.slots.RefinableString100}}


  • If you have a new question, please ask it by clicking the Ask Question button. Include a link to this question if it helps provide context. - From Review Commented Aug 23, 2023 at 16:34

Have you tried using the Adaptive Card model?

click on Adaptive cards and click on Custom. In the "Edit results template" click on {} copy the code and paste it in the adaptive card payload.

where you want to show this Refineable string. Add a TextBlock in the container and add Text: ${string($data.RefinableString100)} to show.

Also make sure you have selected RefinableString100 from the Selected Properties (Page1) of the pnp search result.

hope this works

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.