0

I want to deploy this SPFx sample inside my tenant @ https://github.com/pnp/sp-dev-fx-webparts/tree/main/samples/react-chatgpt-app. Now inside the package.json file below is mentioned regarding the node version:

{
  "name": "react-chat-gpt-message-extension",
  "version": "0.0.1",
  "private": true,
  "engines": {
    "node": ">=16.13.0 <17.0.0"
  },

While my node.js command prompt has this version:

C:\Windows\System32>node -v
v14.18.1

Now I build >> deployed and tested the web part and it is working well.

So is there any issue or compatibility issue I am unaware of? and should I upgrade my node.js command prompt to use node version which is in between "node": ">=16.13.0 <17.0.0" ?

6
  • 1
    Which version of SPFx generator are you using? Check @microsoft/sp-core-library in package.json file. Mar 8, 2023 at 11:21
  • @GaneshSanap i am have this version "@microsoft/sp-core-library": "1.16.1", ? why you are asking .. thanks?
    – John John
    Mar 8, 2023 at 11:32
  • 1
    For this version of SPFx generator, ideally you should use node js v16.13+. Mar 8, 2023 at 11:35
  • @GaneshSanap but the web part got deployed using node v14 without issues.. so should i upgrade or i should be fine
    – John John
    Mar 8, 2023 at 11:53
  • 1
    I think it should be fine as it is deployed and working fine. Let's also wait for other experts comments. Mar 8, 2023 at 12:28

1 Answer 1

1

For SPFx generator v1.16.1, it is recommended by Microsoft to use node js v16.13+.

For detailed list of compatible versions of SPFx generator and Node.js, you can follow this compatibility matrix documentation: SharePoint Framework development tools and libraries compatibility

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.