0

I have a list with unique permissions. As a new item is created, with a flow, I delete all permissions (stop sharing) and assign new ones to some group using http call with roles assignment. I realized I the edit permissions I am giving - despite correctly displayed - are not working. Even providing owner permissions works! In this case LHDBOT01 has owner permissions (provided with the flow) enter image description here But when LHDBOT01 tries to modify this item... enter image description here He's getting this error message enter image description here

Of course, I don't want to give this user edit access on list level...

Some suggestions?

7
  • Is user able to edit item using "Edit" button at the top (in list command bar)? What permissions are granted to user at "site" level? Mar 3, 2023 at 10:21
  • Have you considered giving them Contribute access at list level? They can only read/write /delete items to the list then. Item level permissions are not great, particularly if the list is large. Mar 3, 2023 at 10:27
  • @GaneshSanap, yes the button is there. But when saving, I am getting the error message
    – Marpio
    Mar 3, 2023 at 10:31
  • @CallumCrowley I have being trying all kind of permissions. View only works, all other having edit features, won't
    – Marpio
    Mar 3, 2023 at 10:32
  • I mean, give the users contribute permission on the list, not the list item. Delete unique permissions on the list item. Mar 3, 2023 at 10:36

1 Answer 1

0

Finally I realized waht's the problem: I set up in the list settings/advanced settings/item level permissions "Create items and edit item that were..." rather than "Create and edit all items": enter image description here Once changed, all works as expected!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.