In my SharePoint 2019 dev, I tried to update a solution, however it is stuck on: "deploying (scheduled at ...)".

I have done the following to solve the issue:
- restarted server
- restarted Timer service in Services and in SharePoint
- ran the following: stsadm -o execadmsvcjobs
- restarted server again
- checked the uls logs, but nothing supsicious

but still no solution. Any help please?

Edit: I see in the logs the following:

Database with Id 5d33b7d5-bd85-5847-2251-e15bc1242f2a was not found in database collection. Returning null.     Timer Job webhook-processing

How can I figure out which database was that?

  • If you have access to DB server then you can try this SQL syntax "SELECT DB_NAME(5d33b7d5-bd85-5847-2251-e15bc1242f2a) AS [Database Name];" Feb 21, 2023 at 10:35
  • Conversion failed when converting the varchar value '<Guid>' to data type int. Feb 21, 2023 at 10:48
  • Kindly give a try to this - SELECT * FROM sys.databases where service_broker_guid='{GUID}' Feb 21, 2023 at 12:35


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.