I have a list on a SharePoint site that is coming from the Content Type Hub. Since I don't know where the content type fields are being used I created a new field on the site list settings and not from the Content Type Hub.


So that field “Next Date for Review” is a calculated “read only” field which is why it is not showing up in the intake form.

However when you click on the view details for an item on the list the new field is also not appearing it looks like it only appears on the list view?

  • How many content types you have in your list? Feb 2 at 6:29
  • If you have Select Yes for "Allow management of content types?" option. This may be a delay problem, you wait a moment, the problem will be resolved?
    – Xyza_MSFT
    Feb 2 at 9:18

1 Answer 1


Try below:

  1. Allow management of content types:

    a. Go to list settings > Advanced settings

    b. Select Yes for "Allow management of content types?" option

    c. Click OK at the bottom of advanced settings page to save the changes.

    enter image description here

  2. Add column to all content types while creation:

    a. Go to list settings > Columns section and select "Create column"

    b. While creating a calculate column, check Add to all content types option

    c. Click OK to save the changes and create a column

    enter image description here

  • Above solution should work for you. If it is not working, you have to manually add your calculated column to respective content type from list settings. Feb 2 at 6:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.