0

I have a SharePoint 2010 style workflow running on SharePoint 2013. One of the users to whom task is assigned is getting following error when he tries to update task.

Sorry, something went wrong

I checked logs and see following errors:

Application error when access /_layouts/15/WrkTaskIP.aspx, Error=Value cannot be null.  Parameter name: item   at Microsoft.Office.Workflow.ListPage.SimpleNameFromItem(SPListItem item) 
    at Microsoft.Office.Workflow.WrkTaskIPPage.OnLoad(EventArgs ea) 
    at System.Web.UI.Control.LoadRecursive() 
    at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Getting Error Message for Exception System.Web.HttpUnhandledException (0x80004005): Exception of type 'System.Web.HttpUnhandledException' was thrown. ---> System.ArgumentNullException: Value cannot be null.  Parameter name: item 
    at Microsoft.Office.Workflow.ListPage.SimpleNameFromItem(SPListItem item) 
    at Microsoft.Office.Workflow.WrkTaskIPPage.OnLoad(EventArgs ea) 
    at System.Web.UI.Control.LoadRecursive() 
    at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) 
    at System.Web.UI.Page.HandleError(Exception e) 
    at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) 
    at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) 
    at System.Web.UI.Page.ProcessRequest() 
    at System.Web.UI.Page.ProcessRequest(HttpContext context) 
    at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() 
    at System.Web.HttpApplication.ExecuteStepImpl(IExecutionStep step) 
    at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

Only this user is facing the issue. Any idea what's going on here?

2 Answers 2

1

A common issue that raises this error is that the current user doesn't have an email in the UserInfo List.

enter image description here

So in your case, ensure that the user-required fields in your workflow are already set in the UserInfo list.

0

Ok I found out that the issue was system was assigning task to some other user with same name. That user is from a different domain and not even searchable in in User Profile Service when you search for profiles. But for some reason task was being assigned to that user. May be this user is left over from some old data as this SharePoint is running since 2013 before I joined this organization.

Problem User: Frank Martin ([email protected])
Correct User: Frank Martin ([email protected])

I deleted problem user from site collection and now task is being assigned to correct user.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.