1

I have a list that is using a lookup from another list - client name. As part of that column I am able to select "Add additional columns from source list".

I have selected a couple of these fields - one of the fields is a date field and despite the originating column not requiring that data is added, is showing as "Required info" on the record where this field is blank. Is there any means to stop this appearing? Thanks!

2 Answers 2

1

You have to change the lookup column settings and make it as non-required column.

Follow steps:

  1. Go to your SharePoint list

  2. Click on column name header. Select Column settings > Edit

    enter image description here

  3. Click on More options on column settings pane

  4. Toggle Require that this column contains information option to No

  5. Save

enter image description here

4
  • thanks Ganesh - unfortunately this is not available for these fields Commented Jan 17, 2023 at 18:00
  • This setting is available for main lookup column in modern experience. Commented Jan 17, 2023 at 18:20
  • sorry I thought you were referring to the other fields - thanks! Commented Jan 18, 2023 at 9:13
  • You're welcome! Commented Jan 18, 2023 at 9:15
1

"Require that this column contains information" is enabled on your lookup column, this means that the additional columns also have this setting enabled. You can disable the "required" option for the additional columns by following these steps:

  1. Go to the list, click the cog on the top right and select list settings

  2. In list settings, select the additional column from the columns section:

enter image description here

  1. Set the option "Require that this column contains information" to "No"

enter image description here

You should no longer see "Required info" in the additional column if it is empty.

1
  • thanks - I tried that but it initially did not update the date field, so I deselected the additional field in "Add additional columns from source list" and then reselected it again - that sorted it! thanks for your help! Commented Jan 17, 2023 at 17:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.