0

I am experiencing an issue with SharePoint 2016 server that when I want to create a new List I am getting this error. From ULS log

Begin CSOM Request

Request is a Cross-Origin request. Origin is : 'domain.com' Host is : 'app server IP'

Request is a Cross-Origin request for a user that was not authenticated using OAuth. Returning 403

The alternate access mapping is configured correctly.

I have tried absolutely everything from Google and this site like RAM, restart etc. but nothing works.

Also the issue only persists when I am opening SharePoint from domain name (URL Rewrite, Web forward server).

If I access the SharePoint locally from the server machine It works greatly. I am using URL Rewrite and Proxy Forward and I think there is some issue with it but also I tried everything even the AI ChatGPT bot but still no luck.

Any tips?

9
  • Have you configured your alternative access mappings correctly? Not sure why you would need the URL rewrite. Jan 11, 2023 at 15:30
  • Hello, Yes It is configured correctly as I checked it multiple times. URL Rewrite is needed because of the DNS. Jan 11, 2023 at 15:49
  • Your rewrite is causing the problem, the domain needs to be configured as part of your AAM rather than rewriting the URL to use the domain you wish. It's in the error message. Jan 11, 2023 at 16:31
  • The Domain is also written in AAM. The Web is accessible but I can not create or save anything on there. Jan 11, 2023 at 17:00
  • If the domain is already configured in the AAM, why do you need the URL rewrite? Jan 11, 2023 at 17:03

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.