I need to give access to all domain users to a single page in my SPO site.

The page is showing information pulled from a list in the site using spfx, and also the user details like logged in user name.

I have given page level Read access to everyone except external users, but the data is not being populated.

On checking the console, I see multiple 403 errors most of which are for api calls. There are also a couple of errors Error making HttpClient request in queryable.

How can I fix this? What extra permission should I give?

p.s. If I give site level View access to everyone except external users, the data is displayed. However, I would like to restrict access to the single page.

1 Answer 1


It sounds like the page is using an API to access data from the list and display it on the page. In order to fix the 403 errors, you'll need to ensure that the API has the necessary permissions to access the list data.

One way to do this would be to give everyone access the list by granting "Read" permission. You can do this by going to the list settings and selecting "Permissions for this list" under "Permissions and Management".

  • Even with Read permission on the list, I am getting the 403 errors. Looks like the actual API call itself is not being allowed.
    – entryton
    Jan 6, 2023 at 21:34
  • can you add more info? for example, actual errors or screenshots? Jan 9, 2023 at 2:07
  • I'm not able to get a screenshot now. Would the error be because API calls are not allowed with a site level read access?
    – entryton
    Jan 9, 2023 at 4:41
  • Without seeing the API calls, it's hard to tell what the issue is Jan 9, 2023 at 15:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.