0

am using sharepoint 2016 onpremises. One Sql Server and one Web Front End(WFE) server, one Application server is there. I am using Sql server 2014 version. I installed RBS for First content Database Successfully using GUI. While installing RBS for second content Database in Sql server it is showing it is configured successfully.And i checked the rbs tables were exist or not using the following command.

USE[contentDataBasename] selectfrom dbo.sysobjects where name like 'rbs%'. It was showing the table .While installing RBS for WFE server in log file it is showing MS SQL Server 2014 Remote Blob Storage configuration failed. Reconfiguration success or error status:1603 . Below command only i ran. msiexec /qn /lvx rbs_install_log.txt /i rbs.msi REMOTEBLOBENABLE=1 FILESTREAMPROVIDERENABLE=1 DBNAME=[your next content database name] FILESTREAMSTORENAME=FilestreamProvider_1 ADDLOCAL=EnableRBS,FilestreamRunScript DBINSTANCE=[your DB server]. I changed HKLM > Software > Microsoft > Remote Blob Storage > value for key 'database' = [probably the name of the content database i initially enabled RBS on]; after that i restarted the server also it is not installing. Finally i used the following command. msiexec /qn /lvx* rbs_install_log.txt /i RBS.msi TRUSTSERVERCERTIFICATE=true FILEGROUP=PRIMARY DBNAME="WSS_Content" DBINSTANCE="DBInstanceName" FILESTREAMFILEGROUP=RBSFilestreamProvider FILESTREAMSTORENAME=FilestreamProvider_1

In log file MS SQL Server 2014 Remote Blob Storage configuration successful. Reconfiguration success or error status:0 But while running $rbss.Installed() command it is showing SQL Remote Blob Storage must be installed on each web front end server and on the content database before it may be used. How to solve this problem?

1 Answer 1

0

You don't touch the registry during the RBS installation. I documented how to do this at Enabling RBS on multiple content databases.

With that said, I'd highly recommend not using RBS. It doesn't offer advantages and increases maintenance and backup complexity by a significant margin.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.