0

I am using the SharePoint Online Classic site. I need to add Modern Site Page under the Site Pages library.

I have tried to add a new page under the Site Pages library. But the add Site Page option is missing while adding a new page.

Please check the below screenshot for more details. enter image description here enter image description here

Is there any way to enable the Site Page option under the Site Pages document library?

Can anyone help me with the same?

1 Answer 1

1

you can try the follow ways:
1, Enable "Allow users to create site pages"
Go to SharePoint admin center -->Settings-->classic settings page-->
Ensure "Allow users to create site pages" is checked.
Restart your browser and re-login, then see if the problem is solved.

2, Add the content type to the library
In Site Pages Library,
go to "Library Settings"-->
In the Content Type Section, click on "Add from existing content types"-->
Search for "Site Page" from the list (you can simply select one item and press "S" on your keyboard to take you to all the content types starting from S) -->
Select "Site Page" and click Add and then click on OK.
Go back to Site Pages Library, click on New and you should be able to create Site Page now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.