We're seeing an odd issue on our farm after migrating/upgrading to SP2019. Normal search results (list items, documents, sites, etc.) are showing up properly for all users. People search results, however, are only showing up for farm admins - anyone else gets "There are no results to display". I assume it's permission-related, so that's what I've been checking.

I've confirmed that the search service/crawler account has full permissions to the user profile service app, and I've confirmed that everyone has read permissions to the mysites web app. In our search service app, the people search content source is set to our main intranet site, but using the url format sps3://site.company.com. According to the crawl log, it crawls properly (right number of results, no errors) every night.

Has anyone here seen this issue before?

Note: In case anyone asks, we upgraded our farm from SP2013 Enterprise to SP2016 Enterprise, then from there to SP2019 Enterprise. It's a small farm, and service accounts did not change between environments. I did set up each environment separately, though, so it's entirely possible I missed something somewhere.

1 Answer 1


Please check the steps from this article it resolved the issue for me in the past. I know it is about SP2013 but not much has changed on the search config.



  1. Set the permissions for the search crawler to Retrieve People Data. Go into Application Management -> Manage Service Applications page. Highlight the User Profile Service Application line. In the ribbon, click on Administrators. Add the Default content access account (check what it is on the front page of the Search Administration page) and make sure that Retrieve People Data for Search Crawlers is checked. Click on OK.

  2. Make sure you type the sps3://hostname into the content sources. This tells the search that this is not just content - it is a My Site service app. If you don't add it, but just list the URL of the MySite Host, the crawler will crawl the content, but not the profiles.

I listed three content sources on mine: http://sharepoint.domain http://mysites.domain sps3://mysites.domain

  1. Create a crawl rule. Go to Search Administration -> Crawl Rules -> Add Crawl Rule. In the Path box, type sps3://, where is the URL for the Web application where you deployed the My Sites site collection.

Do a full crawl.

There are other configuration setting to follow, as well. I found this page to be useful: http://technet.microsoft.com/en-us/library/hh582311.aspx

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.