Last week I created a new Teams site. I am one of 3 owners, and I confirmed I'm still an owner. I have no other SharePoint authority at the farm level. I'm just a Teams site owner.

Last week I created a new "Editors" group and changed the permissions for the Document Library so Editors have Contribute and changed Members to Read access.

Document Library Permissions

Today when I go back into Site Settings, I no longer see the "People and Groups" option on my Site Settings. I can go to the user.apsx page by changing the URL (and I was able to make changes), but I'm sure I didn't do that last week.

Why is the "People and Groups" link gone? Is there any other way to navigate to the page besides changing the URL manually?

Here are my settings:

Site Settings

1 Answer 1


There is another path to get to the page, but you have to start from the right place and go the right way. Once you get into the SharePoint Site Setting page, you can't get there.

  • Open the Team and select the Files tab

  • In the header, click the three dots and then Open in SharePoint

  • In the upper right corner, click the gear icon, then click Site Permissions

    Settings menu

  • In the Permissions sidebar at the bottom, click Advanced permissions settings Permissions sidebar

This will open the user.aspx page.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.