0

I have a list with 3 columns that has the type Choice. When I add the choices for the column I check the checkbox Allow 'Fill-in' choices which allows the user to fill in other choices.

But when a user enters his own choice SharePoint mark the choice as a bullet. How can I fix the 3 columns with the type Choice that when a user enters his own choice it doesn't get marked as a bullet.

It has to be plain text no markup.

enter image description here

1
  • Do you want to remove border box (choice pill) only when fill-in choice is added or for all the values, even when option from choice fields options is selected. Oct 2, 2022 at 8:41

1 Answer 1

1

It is showing choice pill / border because of SharePoint JSON formatting applied to your choice column.

Follow below steps to remove choice pill (border) format from fill-in choice values:

  1. Go to your SharePoint list, click on settings (Gear) icon and select "List settings".

  2. From list settings page, scroll down to "Columns" section and click on choice column name for which you want to make changes.

  3. From column settings page, scroll down to "Column Formatting" section.

  4. Copy JSON code in text box and paste it in visual studio code (or your favorite text/code editor).

  5. Scroll down to the bottom of JSON code and replace below line with "":

    "sp-field-borderAllRegular sp-field-borderAllSolid sp-css-borderColor-neutralSecondary"
    
    
  6. Copy the modified JSON and paste in text box under "" option on column settings page

  7. Click "OK" to save changes.

Before changing JSON:

enter image description here

After changing JSON:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.