0

A few days ago external guest users could edit and move files, I changed the settings site permissions and turned off delete, this then turned off move. Realising this I turned delete function back on, but users still cannot move or copy, but can delete.

When users go to move a file it says "Unable to move the file to the destination because content approval is enabled on this library."

However:

  1. Versioning: Require content approval for submitted items is set to NO (see below pic)
  2. Permissions set to Edit - with delete items and approve items ticked. (see below pic)
  3. No flows or approvals

But when I go to manage access - direct access, the settings show cannot edit (see below pic). If I change this to edit, it temporarily changes site permissions to contribute, before reverting back to cannot edit, and returning site permissions to edit.

I've also had some weird new groups appear such as: SharePointHome OrgLinks Admins, SharePointHome OrgLinks Editors, SharePointHome OrgLinks Viewers

While the external users are suddenly showing in: Limited Access System Group for List (edit permissions set), Limited Access System Group for Web (edit permissions set)

Further to this the Admin homepage is showing a warning; "something went wrong, could not display guest access information" (see below pic). Can anyone please help?

enter image description here

enter image description here

enter image description here

enter image description here

2 Answers 2

0

First,check the setting of Draft Item Security. Draft Item Security Then set the "Approve Items" permission for the permission level and this sole setting allows the user to move a document to another SharePoint online document library. Approve Items

======================= As a supplement to your question, some introductions to some of the group names that appear.They are related to the Links list on the SharePoint home page.

1.SharePointHome OrgLinks Admins--These people have full control over the Org links list on SharePoint home. They can give other people permission to edit the list.

2.SharePointHome OrgLinks Editors--These people can edit and manage the Org links list on the SharePoint home. Everyone who visits the page will see Org links.

3.SharePointHome OrgLinks Viewers--These people can view the Org links list on the SharePoint home.

Regarding the Limited Access, it enables a user or group to browse to a site page or library to access a specific content item when they do not have permissions to open or edit any other items in the site or library. This level is automatically assigned by SharePoint when you provide access to one specific item. You cannot assign Limited Access permissions directly to a user or group yourself. Instead, when you assign edit or open permissions to the single item, SharePoint automatically assigns Limited Access to other required locations, such as the site or library in which the single item is located.

1
  • Hi, thank you for explaining the SharePointHome groups this is much appreciated. I understand regarding the limited access, I was just explaining the groups showing and their set access. In regards to the steps of versioning and approve items, as mentioned in my post I had already checked these are set accordingly, which they are. I've read loads of topics on this, and read even workflows can be the cause, which is why I mention none are set. If you have anything else I could try, would really appreciate it.
    – Vie
    Sep 8, 2022 at 13:22
0

In case it helps others:

  • Delete 'deleted users' in Azure
  • Delete unique permissions for each folder
  • Delete guest users from SharePoint, and check they are deleted from groups
  • Delete limited access groups
  • Personally I also deleted SharePointHome OrgLinks (they were not showing before hand or on another SharePoint site)
  • Make sure in edit the option "Add items to lists and add documents to document libraries." is ticked.

All this and it's finally working again. But yes, I've had to re-add and redo permissions, but its working at least.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.