I have:

SP2010 rented from a company. 1 site collection
I have IE 9.0.8

For about a 6 months I have this consistent problem.

When I click on a Word doc or Excel doc, I get a choice to edit, I do so.

Word opens, asks for my password. I put it in, and then word crashes. This also happen with Excel.

What I do, and this is a real pain, download the doc to my pc, check out, edit doc, upload then check in.

I am not sure what the problem could be. I have tried this on, 3 PC's and 2 laptops. Same thing.

This is the error message in work:

roblem signature:
Problem Event Name: APPCRASH
Application Name:   WINWORD.EXE
Application Version:    14.0.4734.1000
Application Timestamp:  4b58fafb
Fault Module Name:  mso.dll
Fault Module Version:   14.0.6112.5000
Fault Module Timestamp: 4e9b28fd
Exception Code: c0000005
Exception Offset:   000000000003d657
OS Version: 6.1.7601.
Locale ID:  2057

Additional information about the problem:
LCID:   1033
skulcid:    2057

I thought this might be a localized error however of 3PC's and 2 Laptops, I find that hard to believe.

I have also tried to setup SharePoint Workspace, however I get a crash as well.

Thank you

  • what edition of SP2010 (Ent/Std/Foundation) ? – Supriyo SB Chatterjee Feb 28 '12 at 15:53
  • @sbc111 SP2010 Foundation – Arthor Feb 28 '12 at 15:54
  • Wish I had the answer, but instead I have the same problem. – user16226 Apr 9 '13 at 16:04

I presume you have the SharePoint 2010 SP1 & Office 2010 SP1 upgrades, etc.

The issues may be addresed by

  1. Adding SharePoint site to Trusted Sites zone (browser security)
  2. File associations: doc, docx, xls, xlsx with Word & Excel (see links below)

Examine File Extensions and File Associations in Win7

Managing file associations in Win7

If file associations appear OK (control panel) - verify & reenter by using PowerShell or manual editing of the registry.

[UPDATE] : Dug up this post which narrows it down to Word's template and registry setting - Troubleshooting Word -- Problems With Word's Registry Entry.

  • Hi, I have done number 1, and 2 is correct anyway. I still get the same thing. – Arthor Feb 28 '12 at 16:50
  • It is SP2010 with SP1. A company called APPS4RENT... – Arthor Feb 28 '12 at 16:51

Is the webclient service running? this is required to allow opening files from the network using WebDAV.

  • where do I find this. Site actions > site settings >??? – Arthor Feb 29 '12 at 0:29
  • No it's in Windows Services. Just type "services.msc" in the search program box in the start menu if you're under windows 7 or vista. Or for XP do Start > Run. – Seb Feb 29 '12 at 7:30
  • 1
    it was not running, however I have started out. Opened up a doc and I still have the same issue. however this time it loaded the doc after putting my PSW and then it crashed. Problem Event Name: APPCRASH Application Name: WINWORD.EXE Application Version: 14.0.4734.1000 Application Timestamp: 4b58fafb Fault Module Name: mso.dll – Arthor Feb 29 '12 at 17:52
  • Hmmm strange issue... I suppose you already try to repair Office Client? Have you tried with another computer on the same Sharepoint website? – Seb Feb 29 '12 at 20:11
  • I have tried other laptops, same thing. I have done a the repair on office 2010 but it does work with office 2007. Question - Is it possible that the vendor who is supplying the service make some error on their side? – Arthor Feb 29 '12 at 22:00

I have had this problem also, I am running Win7, SP2013, Office 2010 and SharePoint Designer 2013. It seems that there is an issue with installing SP designer causing this same conflict. I ran a repair on Office and it seems to be working. This fix also worked for another user in the office also. Others without the SharePoint designer have not had this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.