0

I spent already whole day googling and trying to implement googled solutions but nothing worked so far... (and yes - I tried many solutions recommended from threads I found here on stackexchange)

Here is the story...

Chapter 1

1+ year ago I played with SPFx first time and at that time everything worked well. I can't remember exactly but it was SPFx version 1.12 or 1.10.

Chapter 2

Today I have entered SPFx world again. This time I've installed newer version of Node.js and all the tool chain for SPFx (yo, gulp, sharepoint generator). And I faced issues that despite everything running fine I don't see my web part in the hosted workbench and always get this warning:

enter image description here

Then there was intensive googling and I did the following:

  1. made sure there is self-signed dev certificate
  2. serve.json file has correct tenant & site url
  3. uninstalled gulp and installed gulp-cli
  4. cleaned npm cache
  5. searched but couldn't find hidden folder ".gcb-serve-data" (that apparently can help to replace dev cert)

Here are my versions:

enter image description here

Chapter 3

So finally I decided to uninstall Node and npm completely and install all from scratch. I did all this but this time I went for 1.14 SPFx version (assuming that maybe latest one is not stable enough).

enter image description here

But it still does not work :(

For reference here is what I see while running gulp serve:

enter image description here

Also for reference:

  • I'm doing all this using the same PC
  • I' following Microsoft article 100%
  • I run m365 spfx doctor two times and first time it said that it doesn't support 1.15 version. Second time it said that I don't have gulp... But I do have gulp-cli and that's what recommended by Microsoft (looks spfx doctor is not up-to-date with latest changes)

ANY IDEA WHAT ELSE IS GOING WRONG???

10
  • 1
    Which version of node.js are you using with SPFx 1.14.0? Commented Aug 12, 2022 at 14:23
  • 1
    Are you able to browse to https://localhost:4321/temp/manifests.js directly in the browser? If so, are there security warnings? Click on the padlock in the left portion of the address bar and ensure your connection is listed as secure. If not, then the issue is with your dev cert which definitely presents itself like this in the online workbench. Commented Aug 12, 2022 at 15:51
  • @GaneshSanap, my bad - I should have mentioned this in my question. Versions I'm using: node v.14.19.0 npm v.6.14.16 Commented Aug 15, 2022 at 9:58
  • @theChrisKent, I assume I should try this while "gulp serve" is running, right? Yes, I'm getting security warning. But when I run gulp serve and url from serve,json is open (aka online workbench) there is no any warnings and httpS is used. FYI - as per documentation 1.14 version does not support local workbench - only online workbench. Commented Aug 15, 2022 at 10:03
  • The online workbench won't show you any warnings and the local workbench doesn't matter. You've got a certificate issue. Until browsing to your local server (while gulp serve is running) works without security errors, you won't be able to use the online workbench. Can you successfully run gulp trust-dev-cert? Commented Aug 17, 2022 at 14:59

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.