I want to get a security group ID by name, so i tried this HTTP request action, by passing this uri (https://graph.microsoft.com/v1.0/groups?$filter=displayname eq 'SEC-Project Repository Hub-Visitors'):-

enter image description here

but i got this error

"error": {
"code": 400,
"message": "URI path is not a valid Graph endpoint, path is neither absolute nor relative or resource/object is not supported for this connector. Resources: groups. Uri: https://graph.microsoft.com/v1.0/groups?$filter=displayname eq 'SEC-Project Repository Hub-Visitors'",
"source": "canada-001.azure-apim.net",
"path": "choose[10]\\when[1]",
"policyId": "",
"clientRequestId": "*****"

any advice please?

1 Answer 1


There's a "quirk" with both the Send an HTTP request and the Send an HTTP request actions. If you have a query string, you need to include a forward slash before the query string starts.

https://graph.microsoft.com/v1.0/groups/?$filter=displayname eq 'SEC-Project Repository Hub-Visitors'
  • thanks it worked
    – John John
    Aug 6 at 12:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.