1

I was trying to start Microsoft SharePoint Foundation Sandboxed Code Service

But it threw The password for the account domainName\empID, as currently stored in SharePoint, is not the same as the current password for the account within Active Directory

I recently changed my domain Password.So that is the possible reason.

But, I also updated the new password in the application pools.

and still getting the same error. what wrong?

where should I need to change the password to make work it.

4

In SharePoint 2010, accounts for Farms, Web Applications and Service App pools can be set from a central location in Central Admin called "Managed Account".

Visit this technet blog for the detailed explanation on Managed Accounts - http://blogs.technet.com/b/seanearp/archive/2011/01/25/updating-passwords-on-sharepoint-2010.aspx

In your case, follow these steps to change the password for SharePoint,

  • Open up the SharePoint PowerShell command prompt
  • Set-SPManagedAccount - UseExistingPassword -Identity DOMAINA\SPSAdmin
  • Where DOMAINA\SPSAdmin is service account that had it's password changed in the AD
  • You will then be prompted for the existing\new password for "DOMAINA\SPSAdmin"
  • Run "Repair-SPManagedAccountDeployment" to verify the passwords are now in sync
  • Next do an IISRESET command
  • Run Repair-SPManagedAccountDeployment to verify that you do not get this message: Repair-SPManagedAccountDeployment : The password for the account DOMAINA\spsadmin, as currently stored in SharePoint, is not the same as the current password for the account within Active Directory. To fix this with PowerShell, run Set-SPManagedAccount -UseExistingPassword

  • The Set-SPManagedAccount -UseExistingPassword command will update the config database and service using by this account.

  • Thanks a lot, It worked. Could you please tell me how to change this identiey. I want to change this user. – Mohit Feb 29 '12 at 9:10
  • 1
    You can add a new managed account using the New-SPManagedAccount command. Please refer this blog for details - blogs.technet.com/b/wbaer/archive/2010/04/11/… – Deepu Nair Feb 29 '12 at 11:14
  • Thanks a lot, Deepu. Yesterday my team entire half day was lost because of this issue. the special id created for install, spfarm account was went for a toss because of account locked out issue, and i have run the set-spmanagedaccount cmdlet and repair-spmanagedaccountdeployment comdlet as well now its working fine. --- _/_ pranaamam... – SaMolPP Feb 1 '17 at 9:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.