0

From some days ago, when I try to start a sharepoint online project I can’t login in popup window.

Visual Studio 2019, Sharepoint Online Provider hosted Project.

When solution opens and click on Sharepoint Add-In project, usually a popup window came to ask for login and password info. This process also happenned on starting the project if not logged In since Visual studio was started (as administrator always).

What happens now is the popup window appears in blank (shows nothing, white window) and some seconds after, it closes an pops up again doing the same thing in a loop. After some loops, VS ask for disconnecting from sharepoint.

If I hold the mouse clicked on status bar of the popup window, before close shows the message “A problem has occurred”, but on release the mouse button, window closes.

I tryed a lot of things. The only thing that worked is to create another user in the same machine (admin permissions) and log in to this account. With this account all works well. But on my account still the same behaviour.

I’ve deleted al folders related to VS temp info within %USERPROFILE%\AppData\Local\Temp

Also deleted VS cache %USERPROFILE%\AppData\Local\Microsoft\VisualStudio\16.0\ComponentModelCache directory

Nothing worked.

With another user created locally on my machine, works fine. Login Popup appears and I can login correctly. Then the process installs the Add-In and I can debug as normal. I think is something related with my user than to VS itself. Some corrupted file or somenthing like that. Destroy and create my user again is not an option by now, I’d like to continue exploring solutions.

I’ve installed VS 2022 and the behaviour is the same. Popup login screen restarts as well on VS 2019.

I’ve made some test on blank scren. When screen appears, made mouse right click button > properties and copied de URL.

This is a URL to login.microsoftonline.com with IDs and hashcodes.

Next step is to past the URL in a navigator (Edge). The sign in screen appears, I log in and goes to Sharepoint site.

So it seems something is broken when VS opens the popup screen. Is it Edge engine? Is it a VS internal navigator? I think not, because the same behaviour happens in different VS versions (2019 and 2022).

Does anyone had some similar ussue?

0

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy