0

I've been pulling my hair out with this one all day.

I'm trying to write a flow to combine a bunch of Lists into one, that will run nightly to keep a master version updated by the child lists. All lists have identical fields. One of them is a multi-select person field.

I've followed the common instructions online, and used an "Apply to Each" to append the people to an array variable. Snip of a Power Automate FLow

Instructions online differ - some say to use email, some to use the "claims" code. I've tried both. I have a compose to check the variable value with this output:

snip of a PA flow - showing array variable value

Then when I get to my "Create Item" block - I have to create the item with a json, as I'm using a dynamic value for the list location. I have this in my item box, with field_4 being the relevant person field: enter image description here

Here's a snip of the results after it runs. This is the inputs box, which looks like it should be working, and looks exactly like what I've seen in other threads: enter image description here

End result, the people don't get written to the person field. There's no error message, and the item is created with every other field showing up just fine.

Any ideas?

1 Answer 1

0

Ok, not a ton of action on this but I finally solved it myself.

Each of my lists were created by copying a template list. For some reason, when copying lists, sometimes the setting for the person field was changed to turn off multi-select.

I had corrected this on all of my source lists but not my target list. So I was trying to write an array to a field that wanted an object. Rather than throwing an error message, it just didn't accept the input and moved on.

Wasn't really an issue with my flow, but just an obscure settings bug mixed with human error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.