0

we've configured Sharepoint SE to connect to the identityserver following https://docs.microsoft.com/en-us/sharepoint/security-for-sharepoint-server/oidc-1-0-authentication

we've performed the trust by automatic metadata endpoint

the token returned from the idp seems fine

we are able to logon successfully but the web application gets trapped in an infinite loop to the idp url

the token passed seems fine

Processed token: {"alg":"RS256","kid":"redacted","typ":"JWT","x5t":"J37iPka4kknsn1_redacted"}.{"nbf":1656599384,"exp":1656599684,"iss":"https://identityserver.redacted.redacted","aud":"redacted.hybrid.client","nonce":"AA1571EECA036redacted310E72F698D1620180950-2044E10A9FredactedE4A0DEE8DD3D55797B08867DE9293E2217881","iat":1656599384,"c_hash":"redacted","s_hash":"redacted","sid":"E432Dredacted9A64BD95A5E77228A0F","sub":"redacted","auth_time":1656599378,"idp":"local","role":"new_admin","is_active":true,"name":" ","given_name":"","family_name":"","email":"redacted","amr":["pwd"]}

but we have an exception in the following call

SPFederationAuthenticationModule.OnSignedIn: /sites/redacted_cert/_layouts/15/Authenticate.aspx?Source=%2Fsites%2Fredacted%5Fcert UrlPathDecode Fail. Error: System.UriFormatException: Invalid URI: The format of the URI could not be determined.
at System.Uri.CreateThis(String uri, Boolean dontEscape, UriKind uriKind)
at Microsoft.SharePoint.IdentityModel.SPFederationAuthenticationModuleV2.OnSignedIn(EventArgs eventArgs)

after these error we get a 302 and the loop continues indefinitely

Has anyone any idea of what could be the issue?

the farm build is '16.0.14931.20284'

thanks

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.