I'm trying to change the column format for a column in Office 365.

This is done through the view > dropdown menu > Column settings > Format this column > Advanced mode.

No matter what column I pick, the schema URL is immediately underlined with an error message:

$ref '/properties/attributes/class' in 'https://developer.microsoft.com/json-schemas/sp/v2/column-formatting.schema.json' can not be resolved.(768)

I can't tell if I can just save anyway and it will work or if it ignores my changes.

Error screen:

enter image description here

Error message:

enter image description here

Similar thread:

SharePoint list column formatting schema do not resolve

2 Answers 2


The error you are seeing is because of an invalid reference in the schema file. There's nothing wrong with your format, list, or environment. The Monaco Editor being used in the formatting tab is attempting to validate the schema (unsurprisingly, you get the same error in VS Code).

The Formatting engine does not validate against the schema so this validation error, while irritating and confusing, won't prevent your formats from working. You can safely ignore the message.

I have submitted a pull request to the schema file to correct the bad references: https://github.com/microsoft/json-schemas/pull/88


It seems that the error does not prevent the code from running, I tried with some example formatting and it seems to be working.

Still, probably something that should not happen.

example json,

   "$schema": "https://developer.microsoft.com/json-schemas/sp/v2/column-formatting.schema.json",
   "elmType": "div",
   "txtContent": "this value has been overwritten"

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.