2

I'm trying to add an HTML into my SharePoint Site Page (Teams Site) and am following the instructions at this link here from Microsoft which guides on how to do so.

Steps:

enter image description here

Sorry, something went wrong. File not found.

More specifics: I'm using modern version of sharepoint without admin rights. I am basically trying to add an html file that users can view instantly (not the code but the output), and hosted on this SharePoint site.

1 Answer 1

0

Make sure you are using correct URL of your .aspx file. To copy the correct URL/path of file follow my answer given at: How can I show a subfolder from anohter SharePoint site?

I followed below steps & it is working fine for me:

  1. Created a HTML file on computer & then renamed it with .aspx extension.
  2. Upload .aspx file to Site Assets library on SharePoint site.
  3. Copied direct link to .aspx file using above mentioned method
  4. Create a modern site page and added "Embed" web part.
  5. Added .aspx file URL in "Website address or embed code" section of Embed web part settings.
  6. Published the page.

Output:

enter image description here

3
  • Hi this did not work, it only returned the same error. Your steps 4-6 are no problem, but step 3 does not appear to work for me. I'm trying a URL which is nearly identical: https://<tenant>.sharepoint.com/sites/<siteName>/SiteAssets/filename.aspx but this still returns the same error? In addition, clicking the (i) info button does not provide me the path. In case it'll help, my URL for the SiteAssets folder which you've recommended me to upload into is https://<tenant>.sharepoint.com/sites/<siteName>/SiteAssets/Forms/AllItems.aspx
    – kodikai
    Jun 5, 2022 at 11:24
  • Try embedding using <iframe> element as mentioned in my answer at: sharepoint.stackexchange.com/questions/296790/… Jun 5, 2022 at 11:47
  • Thanks - yes I've tried that too but the issue is that the page itself doesn't even load either.
    – kodikai
    Jun 5, 2022 at 15:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.