1

I'm using the "Send an HTTP request to SharePoint" action in a Power Automate flow. If I set the URI to be:

_api/web/lists/getByTitle('myListTitle')/items?$filter=Title eq 'Example'

It works as expected, finishing in under a second and returning the correct fields. However, if I set it to filter by a different column like "Descr":

_api/web/lists/getByTitle('myListTitle')/items?$filter=Descr eq 'Example Description'

The flow then says "1 retries occured." and never seems to end (at least, not within an hour).

Am I doing something wrong, or is there something specific to my situation that could be causing me this trouble?

Thanks for any help you can offer.

5
  • What is the type of column Descr ?
    – Saira
    Commented May 31, 2022 at 23:42
  • If Descr column is of type "Multiple lines of text", it will not work as it does not support filtering. Also, you have to use the internal name of columns in REST queries. Commented Jun 1, 2022 at 9:42
  • @Saira Descr is a single line of text.
    – Duck
    Commented Jun 1, 2022 at 14:48
  • @GaneshSanap Descr is a single line of text. It's internal name was field_2, I changed it to that and it worked! Thank you.
    – Duck
    Commented Jun 1, 2022 at 14:51
  • Great, glad it worked for you! Commented Jun 1, 2022 at 15:04

1 Answer 1

1

You have to use the internal name of columns in SharePoint REST API queries.

So, make sure you are using correct internal name & supported column type for filter in REST API.

You can get the internal name of your column by following this article: How to find the Internal name of columns in SharePoint Online?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.