0

I have a large library (approx. 230,000 items) that has been migrated from SharePoint 2010. This library, although large, is well structured employing two levels of folder then using metadata to arrange files within.

The library has a default view that has group by enabled to group items by a custom "document type" column. When using this default view, at the second-level folder level a "show all" link appears after the first 30 folders are displayed.

When you click on this, it shows all the subfolders, but also automatically applies a filter to the view to the effect of "document type = empty)". This then causes all the files within the subfolders to not display.enter image description here

When you click on this, it shows all the subfolders, but also automatically applies a filter to the view to the effect of "document type = empty)". This then causes all the files within the subfolders to not display.enter image description here

There are no settings within the view that are making this happen - I've changed the default item limit and that makes no difference below the top-level, there are no filters applied to the default view, it only occurs when group by is enabled.

Anyone else had something similar? I know i've had a few issues with group by (grid view not showing etc.) in the past.

Thanks, Anthony

1 Answer 1

0

This is by design.

When you click "Show all" in a grouped view, it filters to shows you the specific group that you wanted to expand. The filter that gets applied to the library is based on which group you clicked "Show all" against.

This filter then stays in place even as you navigate into subfolders. I don't think it should, but it does. There's nothing you can do in the list or view settings to change this behaviour.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.