1

I have the following column formatting:

{
  "$schema": "https://developer.microsoft.com/json-schemas/sp/column-formatting.schema.json",
  "elmType": "div",
  "txtContent": "@currentField",
  "attributes": {
    "class": "=if(indexOf(toLowerCase(@currentField),'07') != -1, 'ms-fontColor-redDark','')"
  }
}

The first line give the following error: $ref '/properties/attributes/class' in 'https://developer.microsoft.com/json-schemas/sp/column-formatting.schema.json' can not be resolved.(768).

Replacing the schema link to https://developer.microsoft.com/json-schemas/sp/v2/column-formatting.schema.json throw the same error.

The list did work properly last week, and with no changes to formatting I get this error and I have no idea on how to troubleshoot this. Same result in both Edge and Chrome.

2
  • I tried using the v2 formatting json and it is working for me { "$schema": "https://developer.microsoft.com/json-schemas/sp/v2/column-formatting.schema.json", "elmType": "div", "txtContent": "@currentField", "attributes": { "class": "=if(indexOf(toLowerCase(@currentField),'07') != -1, 'ms-fontColor-redDark','')" } } . Can you try applying the formatting on any other column or try to change the formatting a little bit to see if the formatting is working or not. Commented May 5, 2022 at 13:31
  • All columns give the same error. Can this be a change from central IT?
    – rozon
    Commented May 5, 2022 at 19:58

1 Answer 1

0

I tried to use your column formatting and it works successfully.

I recommend you do troubleshooting, please try to change the formatting and then apply it to the other columns, check if the error still exists.

1
  • Thanks, but as stated I don't know how to troubleshoot this. Want to point me on my way?
    – rozon
    Commented May 9, 2022 at 5:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.