0

We have a SharePoint site named "tgbtgb" which only allow sharing with existing guests, as follow:-

enter image description here

Now we wanted to invite a new external user. so we did these steps:-

  1. Inside azure portal we create a new guest account as follow:-

enter image description here

  1. then once the account got created (before the user access the invitation link) >> we add the external user to a SharePoint group under the above site >> where the user got directly added to the SharePoint group.

  2. now the external user got 2 emails, as follow:-

enter image description here

&

enter image description here

now the external user accept the first invitation and got registered as guest. but the second email, had no link to the site, as the site name tgbtgb is not clickable! + also when the user try to navigate to the site by typing the site url inside the browser, the user got this error message:-

enter image description here

although when i checked the external user permission inside the SharePoint site >> i got that the user already have Edit permission as follow:-

enter image description here

so not sure what is going on? why the user can not access the site he has edit permission on ? also when the invitation email has the site title as UN-clickable? Thanks

1 Answer 1

0

It sounds as though you're attempting to use Azure AD B2B integration with SharePoint Online for the management of guests but you may not have completed some of the initial configuration required. I would read the following article and decide if you do want to use Azure AD B2B for the management of SharePoint Online guests.

SharePoint and OneDrive integration with Azure AD B2B

To enable this integration, you will need to run the following PowerShell cmdlets against your SharePoint Online tenant:

Set-SPOTenant -EnableAzureADB2BIntegration $true
Set-SPOTenant -SyncAadB2BManagementPolicy $true

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.