2

"Export to csv" in sharepoint list gives our customer the message of "Sorry, you don't have access." while "Export to Excel" works for the same user. The main concern is for Mac users who only have "Export to csv" option. Any suggestions? Thanks enter image description here

enter image description here

4
  • Ha! I'm having the same problem. It was working up until a few days. I have full control on the list, so it's not a permission issue. The Export to Excel works. I asked the SP admin to take a look at the logs. Commented Mar 18, 2022 at 14:15
  • Thanks @Patrice. I have also noticed that the lists which contain linked fields like lookup or metadata, "export to csv" does not work. Would you please share your information, when you know more please?
    – MirSa
    Commented Mar 18, 2022 at 14:45
  • 1
    We're having the same issue at my day job. My admin account is fine exporting. But regular users have the issue on some lists. It was suggested a lookup column could be the culprit, so the common one amongst the lists was added to my test list. Which broke things temporarily (the access message in question). Problem is it was temporary, export now works on that list. And one other list (of a dozen+) still works fine. Good luck to us all.
    – Vagari
    Commented Mar 22, 2022 at 14:17
  • I don't know what to say, our admin did nothing (with my account) and now it works. Our hunch is that, although I had "full control" on the list, I might not have had (if I can say that word) the right permissions in dependent/top level object (content type). I read that MS changed the content type model push vs pull, maybe a problem with those permissions, which the admin auto-magically fixed it by running export. Commented Mar 24, 2022 at 12:49

1 Answer 1

0

I had a user report this same thing 2 days ago. What i have noticed is that If you have SCA rights, then you can export to csv, but i realize not all have that permission level. Glad to know that we can just tell people to use the export to excel in the meantime.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.