2

I've encountered a big issue on workflow. I designed a very simple workflow with Action "Send Email" on SharePoint Designer 2010 for email testing, as well as workflow process. All things were configured correctly. I created a Custom list and then created a new item. The workflow started, however, it was stopped immediately.

From workflow history, there are two events: - <Name of workflow> failed to start. - <Name of workflow> was cancelled by System Account.

I've tried to change Web Application application pool account and then reset IIS several times but it still doesn't work.

I don't know exactly what happens but in the past when testing on SharePoint 2010 RTM, I didn't have any issues. Currently I'm using SharePoint 2010 Service Pack 1.

1

Did you create your workflow in SPD under a "System Account" login? If so, it will be used to execute your workflow instances. But SharePoint doesn't allow to automatically start declarative workflows under System Account.

If it's not the case you should find exact reason of the error in SharePoint log. What does it say?

  • I think Workflow basically runs under System Account. Even I changed login in SharePoint Designer but it still hasn't worked so far. – Thuan Feb 24 '12 at 16:12
  • The workflow can't start AUTOMATICALLY under the System Account - that's what I'm talking about. And the SPD workflows run under account they was created. BTW if it's still not the case (if it's the case there must be an according exception in the ULS) there must be a detailed exception in ULS - did you check this out? – Alex Boev Feb 24 '12 at 17:20
0

Based on my experience, Workflow got cancelled because of few reasons:

  1. The Account which has been used for publishing the workflow does not have permission to Send email (as in your case). It is recommended to use "Impersonation step/App step" if WF is written using SP designer. If WF is written using code then use SPSecurity.RunwithElevatedPrivilege to send the email.

  2. If the fields down not exist Or it has title/name mismatch while it is being updated by the workflow.

Do check on these situations. Hope this helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.