0

I am currently trying to configure a new SP2019 on prem server to host multiple Web Applications that all use Hostname Site collections. These web applications are assigned virtual IPs and share the same port (443). I can ping the IPs, however when going to a site collection via the browser it always (and quickly) results in a 404.

I feel like this is an IIS issue, however bindings appear correctly to me and both IIS and ULS logs aren't saying anything that stands out to me. Is there a configuration step I am missing? Has anyone experienced or has has insight into this situation?

Main article I followed while attempting configuration

Steps:

  • Create Web Application
$WebAppName = "Collaboration"
    $HostHeader = "Collaboration.company.com"
    $WebAppURL = "https://"+$HostHeader
    $WebAppPort = 443
    $ContentDBName = "SP19_Collaboration_Content"
    $AppPoolName = "Collaboration AppPool"
    $AppPoolAccount = "company\account"
    $AuthProvider = New-SPAuthenticationProvider -UseWindowsIntegratedAuthentication -DisableKerberos
    New-SPWebApplication -name $WebAppName -port $WebAppPort -hostheader $HostHeader -URL $WebAppURL -ApplicationPool $AppPoolName -ApplicationPoolAccount (Get-SPManagedAccount $AppPoolAccount) -AuthenticationMethod NTLM -AuthenticationProvider $AuthProvider -DatabaseName $ContentDBName -SecureSocketsLayer
  • Create root-site collection

Done via Central Admin

  • Configure WebBindings
Import-Module WebAdministration
    #IPAddress is virtual IP 
    New-WebBinding -name "Collaboration" -IPAddress "x.x.x.90" -HostHeader '' -port 443 -Protocol "https"
    (Get-WebBinding -Name "Collaboration" -Port 443 -Protocol "https").AddSslCertificate("cert thumbprint","my")
    Get-WebBinding -Name "Collaboration" -HostHeader "Collaboration.company.com" | Remove-WebBinding
  • create test site collection
New-SPSite “https://collabtest.company.com” -HostHeaderWebApplication (Get-SPWebApplication ‘Collaboration') -Name “Demo collaboration site” -Description “Demo site” -OwnerAlias “company\me” –SecondaryOwnerAlias “company\notme” -Template “SITEPAGEPUBLISHING#0”
  • create A record in DNS

name = collabtest

fqdn = collabtest.company.com

IP Address = x.x.x.90

After the above steps I am able to ping, and get a reply so traffic must be reaching the SP server, it just cant find the web application?

Before I took over setup, our systems team did create a web app with hostname site collections but it was bound to all IPs on port 443. Is it possible this earlier web app is causing problems?

1 Answer 1

0

So apparently I was messing up with my understanding of the virtual IPs. Binding a site to an IP in IIS does not make that IP available on the machine. In order to get the server responding on those IPs you have to edit your networking settings/adapter advanced options and add them.

The below link can walk you through it.

https://aptaredocs.veritas.com/10.0/index.html#page/System%20Administrator's%20Guide/$H_95.html

Once the virtual IPs were configured, the sites started responding right away. The 404 error I was getting was actually a different machine I wasn't aware of.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.