We have a SharePoint field named "options" of type Choice and which allow Fill-in, as follow:

enter image description here

Now if we create a new list item and we type-in a new choice (for example "MY NEW CHOICE"), as follow:-

enter image description here

and we save the new list item, then the Choices inside the field definition will not get modified (will not contain the new choice). but when we create or edit a list item >> the Choice field will show the new fill-in choice, as follow:-

enter image description here

so is this normal? or my tenant has an issue, since the new fill-in choice will not get updated inside the field's definition choices (which will only contain 3 choices; A,B & C without the fill-in choice "MY NEW CHOICE"), as follow:-

enter image description here



2 Answers 2


You're correct, there seems to be a change in functionality which isn't consistent with how choice columns have worked in the past.

Also, if you edit the choice column using the modern UI, it will still not show the additional choice that has been added by the user (despite it now being available in the dropdown when creating a new item).

It's quite possible that this is a bug. In that case I would recommend contacting Microsoft support via the admin center for further clarification. You can create a new service request via the Microsoft 365 admin portal. In the menu section, you'll see the "New service request" option within "Support".

Alternatively, you could use a managed metadata column. I find managed metadata columns to be far more flexible than choice columns anyway.

  • thanks for your reply.. so you mean previously the the fill-in option will get added to the choice's options inside the field definition?
    – John John
    Feb 11, 2022 at 14:45
  • No, I mean fill in options used previously would not appear in the dropdown when creating new items. Feb 12, 2022 at 17:35

I've just discovered this same disappointing issue! I had even thought maybe the Drop-Down Menu was pulling from the existing values in the field, but when I updated the values to eliminate an undesired choice, it didn't help.

I found that the setting for "Display choices using: Drop-Down Menu" causes this behavior, but the "Radio Buttons" option only shows the settings-specified choice list and one for "Specify your own value: Enter value here", which is my preferred behavior.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.