2

This only started happening recently. Possibly after a patch install. I was only contacted after the issue was found. I had nothing to do with server upgrades, so I am not entirely sure if they are the culprits.

There are several document libraries that use mandatory managed metadata fields. Users are asked to fill in these fields when they upload documents. This has been working for over a year without issue. Suddenly, in the modern experience, the managed metadata fields show as "Required info" error in the modern view. If you select one of the items and look at the details, the fields are actually all filled in correctly. If we switch to classic SharePoint, all the fields show up with the values as expected. I tried running the Product Configuration Wizard as I saw that there were some patches installed over the last couple of months. Found a missing feature and fixed that. But that did not fix this problem. I created a new Document Library and a new Term Set. Added a new field using the new term set and made it mandatory. Upload a document and properly set the field... same problem.

So, question is. Is there a bug? Is the site set up incorrectly? I have been using Managed Metadata for many years, this is the first time I see this issue.

This is a preview in modern view:

enter image description here

And this is the same group of files in classic view:

enter image description here

Thanks!

2 Answers 2

0

@Luis: You have few choices here, in my opinion, none of them are satisfactorily self executing except the all of the above method.

This problem stems from the fact that SP performs the upload prior to the designation of its SP metadata. In my opinion, if the process were reversed - whereby the user entered the metadata before the file upload, this entire issue could be avoided.

  1. Train your users that they need to fill in the data. (Easy). Create pre-recorded video(s).
  2. Create a flow and train them to respond to notification from the flow that will nag them about incomplete or empty fields (Medium). Integrate this into the video training above.
  3. Create another video acclimating your end users to the settings below: #3 & #4. You will need to clearly explain the effect of both #3 & 4 to your users, i.e.: that only the uploader of the document and the “approver” user will be able to see it.
  4. In the Library Settings —> Versioning Settings menu, “Require approval for submitted items?” Set to Yes. You need to designate a user with Approval permissions to the library. AND
  5. In the Library Settings —> Versioning Settings menu, Ensure that the “Create a version each time you edit a file in this document library?” Field to: “Creare major and minor (draft) versions”. AND set the “Draft Item Security” field to “Only Users who can approve items (and the author of the item)”

All these options combined will be a best effort on your part, and yet there will be users who simply are too dumb or such infrequent users of SP to follow instructions from their admins. Furthermore, those users, who are usually impregnable to training, will have to learn the hard way because of #4

If this solved your issue, please mark as answer

1
  • The problem is that the users have been trained to enter the data and in fact all the data is there. The "Required Info" message appears only in modern view even though all the data is filled in. In classic view, you can see all the values are there. If I choose the "Files that need attention" view, which would show me all these files with missing data, it is always empty.
    – Luis
    Mar 6 at 13:05
0

I'm having the same issue on one SharePoint 2019 environment. The issue happens if we configure a library or list like this:

  • Add a managed metadata column to the list / content type
  • Set this column to be mandatory
  • Make it a single value column
  • Use the modern view

IF we change the column to be either not mandatory, use a content type that uses the same column but as not mandatory, use the classic view or make the column multi-value the values are shown. Otherwise we get the "Required info" message for all values as well. I believe it is related to a SharePoint or Windows Update, because I have other SP2019 development environments that do not have this issue (and are not patched to current levels).

Although this is not the solution I hope it might help someone with similar problems, as this is the only post I found that has this issue.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.