0

I have a custom list in SharePoint online where I can no longer edit from the item details view in Modern Experience. I can edit in Grid View, and I can view an item or create a new one in item details view, but when I try to edit an item in the details view, all I see is this:

empty edit screen

If I view the item, it's normal:

view mode

And if I create a new item, it works as expected:

create new

My Form options are set to use the default Edit form: form options

If I go into Classic View, then the edit form does display as expected.

I've tried changing from classic to modern and back, tried deleting any possible custom Power Apps forms, turned manage content types off and on, tried different browsers, tried deleting all list items and nothing has helped.

When I go into the console view, there are a pile or errors: failed to load resource

refused to get unsafe header

react error

Other lists on the same site work as expected. Any idea how to get the Edit Item to display the content again?

2 Answers 2

0

So, it looks like the SharePoint UI changed at some point and I didn't notice. I believe in the past that if I clicked on an item to view it, the detailed view opened up in read-only mode (it displayed the fields, but none of them were editable). In order to modify the item, I first had to click on an edit link in the header. In the current version, the only "Edit" I see is "Edit All". When I clicked on that, it was throwing up the empty screen.

The default behaviour now, though, seems to be to open the item in edit view, so I can click directly on any field and edit, without having to click anything to enable the edit functionality. The "Edit All" link seems to be to somehow edit multiple selections in the detail view (maybe if you want to update a field to the same value for 20 items?), and it doesn't display any of the fields if only 1 list item has been selected.

2
  • According to your description it seems like some custom scripts cause this issue. Did any other users add custom scripts to this list? Feb 2, 2022 at 7:55
  • Good point - I'm quite sure no one has added any scripts, and the same errors appear when I am successfully able to edit an individual item. Checking further, they are also there when I just look at the list without trying to edit, and also appear when I go to other lists in other sites in our environment, so they must be related to our environment setup. I'll take that part to our IT team, even though it doesn't seem to be directly impacting the issue above.
    – Darryl
    Feb 3, 2022 at 16:21
0

I just fixed this same problem on my list. In my case, I had two content types, and only one of them was showing blank on "edit all." To fix the issue, I disconnected the content type from the site collection level configuration by changing all the items which were defined as the type which was broken, to "item" content type - and than deleting the content type which was failing. Next, I copied all the orphaned columns from the content type I deleted (which were now "list" columns) to the "item" content type. When I tested, the "edit only" worked. Then I renamed Item to be the name of the content type I deleted.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.