0

New to SharePoint 2019 on-premise environment.

Search works perfectly fine when used in "http://sharepointserver/" but when tried over the configured HTTPS URL "https://sharepoint.example.com", the search gives the error below.

http-error

Crawl logs show that it can crawl the data successfully over the HTTPS.

Additional information:

  • sharepointserver.domain1.com - Internal AD Domain - AAM: Default
  • sharepoint.example.com - External Domain added to DNS - AAM: Intranet

I also checked the following:

  • All services are started
  • Restarted SharePoint Timer service
  • Search Service is associated with the web app
  • Disabled Windows Server Firewall but still same error
1

2 Answers 2

1

I finally solved it. Extended the storage of the disk (we had 50gb free before, now over 100gb) and it somehow started working.

0

Are you using any kind of proxy between client and SharePoint Server?
It would be nice to check IIS logs to find exact HTTP status code for your search request.
Also, try to disable HTTP/2 if it's present in IIS bindings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.