0

I have two Sharepoint Lists, one of which has a Primary ID field that is a Calculated Field that simply equals the Sharepoint generated ID field. Table 2 has a Lookup field that pulls in this new Primary ID. However, when it pulls in that number, it has ten trailing zeros. The field that is being looked up from Table 1 (and is a calculated field) is a Single Line of Text. Why is the lookup adding zeros to a text field and how do I get rid of them? I tried changing the format of the Calculated Primary ID field to Number and setting the decimal places to zero, however the Lookup no longer functions when I do that.

Thanks

0

Change the calculated field through =TEXT(ID,"0"), which converts a value to text in a specific number format:

enter image description here

Then lookup it in another list as shown below:

enter image description here

More information:

https://support.microsoft.com/en-us/office/text-function-4b46e545-e612-4c84-ac23-edfa68007945

2
  • That worked! Thank you so much
    – zestern
    Jan 12 at 14:58
  • Please remember to mark it as answer, It will help others who meet the similar question in this forum.
    – Julie_MSFT
    Jan 13 at 7:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.