1

I'm troubling with issues when trying to deploy Spfx command Set extension using sppkg in Sharepoint Server 2019

It work fine using debug url after running gulp serve

but when i moved to deploy it using sppkg package it doesn't worked like using debug url

I have added sharepoint app successfully like below sharepoint app added successfully but no command set are available then i found no json file and manifest.js are loaded in page i have checked my package-solution.json and "includeClientSideAssets": true to include all app assets in sppkg file like mentioned in officiel sharepoint framework support doc sharepoint framework 2019 support and sharepoint framework 2016 support

Then i passed to include dependencies using cdn in write-manifests.json config file

I have created library to host assets files and i have also used Style library and used their url in manifest config, both of them didn't work

then i tried to host dependencies in local IIS without result

at the end i have created azure storage and azure cdn ( i kept this solution at the end juste for testing) and here the strange i did not find external hosting from azure in my sharepoint site enter image description here

1 Answer 1

0

I found a solution for my problem, my problem was not related to CDN, i have just left cdn path in write-manifests.json empty

then i found that the id in pageCommandSetCommandSet.manifest.json was not the same for ClientSideComponentId in elements.xml

As mentioned in officiel doc Build your first ListView Command Set extension

Note the following XML structure in elements.xml. The ClientSideComponentId property has been updated to the unique ID of your ListView Command Set available in the ./src/extensions/helloWorld/HelloWorldCommandSet.manifest.json file.

2
  • Quick question: did you use YeoMan to create the project scaffolding? Jan 6 at 6:18
  • Yes of course i use yeoman generator v 3.1.1 to create my project But i created an extension inside an other project Jan 6 at 8:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.