1

I have a form that connects to a SharePoint list, and some of the DataCards are comboboxes with two text options. I'm trying to use two of them inside an If to display a warning if the combination is wrong. I have tried the following:

  • DataCardValue3.Selected = "string", the error here is that I'd be trying to compare Record to String
  • DataCardValue3.Selected.Value = "string", I believe this should work but it doesn't, not because of an error but because it says the selection is "empty", like nothing was selected yet but it has
  • DataCardValue3.SelectedItems within a concat with "" as separator, this to extrat the elements of the table that SelectedItems would get me, still came up empty
  • DataCardValue3.Selected.NameOfColumn, this because a combobox can apparently have data from more than one column but since this is a form connected to sharepoint automatic field in my case it doesn't, and it just gives me an error
  • DataCardValue3.Selected.Result, I've seen this in apps other people from my organization have made, it just gives me an error

I'd appreciate any guidance

1 Answer 1

0

it's simple, you just need to test if your "string" text Contains in DataCardValue3.Selected Record

Example:

If("string" in DataCardValue3.Selected, "String Checked", "String is not checked");

Cordially.

4
  • Thanks, I tried but it says "Record can't be used in this context" about it being used after the "in" I assume. I put SelectedItems and it did accept the code, but it didn't get a match. Condition returns false.
    – TwoPointNo
    Dec 28, 2021 at 14:33
  • selectedItems are for comboxes not for Checkboxes if i can say that. I got an idea it can work if you can share your screen with me ! Dec 28, 2021 at 20:21
  • Hey Aimen! It was a combobox, I figured out a work around, I went and made the fields text fields in the SP list and added comboboxes independent to the form that updates the list. By doing that I used combobox.Selected.Value in the Default property of the automatic form text input for those columns and there it did work. Seems the issue is with reading the content of the fields added automatically when you add a for connected to a list, so this is the work around. Thank you a lot.
    – TwoPointNo
    Dec 29, 2021 at 12:59
  • Yeah, even there is another workaround using Powe Apps Collections Dec 29, 2021 at 13:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.